Eclipse compiler error when running using Java 8

Description

Environment

None

Activity

Show:
Arul
May 21, 2015, 6:14 PM

Btw, this works in 3.0-SNAPSHOT version. When do you plan to release 4.0?

Volker Voßkämper
May 21, 2015, 10:47 PM

Hi Arul,

3.0-SNAPSHOT is the snapshot towards release 3.0 (not 4.0)
You can find the roadmap here: https://cenote-issues.atlassian.net/projects/JAS/versions/10900

Your problem is not clear to me. Compiling a report using JasperStarter is not an Eclipse task.

Can you reproduce your problem using bash or windows cmd.exe?

Regards
Volker

Arul
May 22, 2015, 11:24 PM

My bad, I meant 3.0. The problem is jasperreports maven dependency has ecj dependency (Eclipse JDT compiler). The ecj version that ships with 2.2.1 does not work with Java 8, but the one that is used in 3.0-SNAPSHOT works with Java 8.

Volker Voßkämper
May 24, 2015, 3:58 PM

Yes, this is a dependency that comes with JasperReports. So there is nothing to do but a quick new release.
I stripped of the less important issues from the roadmap.
Release 3.0 will come soon.

Volker Voßkämper
May 24, 2015, 4:06 PM

JasperReports-6.x.x comes with newer jdt which works with Java8

Fixed

Assignee

Volker Voßkämper

Reporter

Arul

Labels

None

Fix versions

Affects versions

Priority

Major